Skype for Business Server Response Groups Migration Gotcha

Noticed something weird during a recent upgrade to from Lync Server 2013 to a new Skype for Business Server pool.

I was double-checking my self against Greig Sheridan‘s very detailed guide and as expected, everything worked just fine.
We tested and confirmed that calls are coming through and the response groups are all working as expected – that was easy.

The next week I’m getting a phone call saying the Response Groups’ managers can’t change some of the settings they used to be able to.
Checking AD permissions – OK.
Opening the Workflow – I can’t see the managers and the workflow is set to “Unmanaged”.

I thought it was just a misconfiguration but then I checked the “Get-CsRgsWorkflow” export we did earlier (Never underestimate documenting!) and all workflows that were set to “Managed: True” are now set to “Managed: False“.

I thought it was a bug, but no – it’s by design. I couldn’t see it in the migration documents (nor thought I should look for it!) but the Microsoft planning document for Skype for Business Server 2015 states very clearly vaguely that “When you migrate response groups from a prior version to Skype for Business Server, the type is set to Unmanaged.”
Here, check for yourself.

I’m not sure if this is the behaviour when performing an in-place upgrade to Skype for Business, but assuming it is.

Advertisements

Server 2012 or 2012R2 Blue Screen when installing Skype for Business or Lync Servers

Published earlier by Microsoft, a Stop error D1 when will occur when you start front-end services on Skype for Business Server 2015-based servers. This will also affect Microsoft Lync Server 2013 Enterprise Edition pools that have at least two front-end servers in Windows Server 2012. This will mostly impact organizations that will perform an in-place upgrade to Skype for Business Server 2015.

This is due to a bug on in Windows Server 2012 and Windows Server 2012 R2. The trigger is a TDI filter driver on the machine that may be used by some antivirus and VPN software.

To resolve this issue for Windows Server 2012 you will need to install the hotfix described in KB2957927 on all Lync 2013 Servers that are installed on Windows Server 2012.

Do determine if you have such a driver installed on your system, look for event 16001 on your system log.
A faster way of finding it out will be running the following command command from an elevated PowerShell window:

get-eventlog -logname system  | ?{$_.eventid -eq "16001"}

Source: Microsoft.